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ABOUT WORDFAST HELP 

Purpose 

This online help will assist you in understanding and using Wordfast Professional Plus (Wordfast). 

It contains step-by-step procedures of Wordfast functions. 

Audience 

This help is a reference for project managers and translators. The audience must be familiar with 

basic translation terminologies. 

Organization 

The help is organized as follows: 

Section Contents 

Section 1  Overview of Wordfast and workflows providing a snapshot of 

Wordfast functions. 

Section 2  Procedure for installing Wordfast. 

Section 3 Procedures for opening Wordfast and a brief description of 

the PM and TXML editor perspectives. 

Section 4  Procedures for PM plug-in tasks. 

Section 5  Information on basic menu options. 

Section 6 Procedures for managing translation projects. 

Section 7  Information on shortcut keys and license management. 

Section 8 Information on common errors and their solutions. 

Conventions  

• All user actions are highlighted in bold to help understand the procedures better. 

• Images are inserted at appropriate places to help you relate to the application interface. 

• The term "Note" precedes any important information that you may need to know while 

performing a task. 

• The word "Optional" follows procedural steps that are not mandatory. 
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Abbreviations and Acronyms 

Term Description 

TM  Translation memory 

TXML   Tracker Extensible Markup 

Language 

XML  Extensible Markup Language 

HTML HyperText Markup Language 
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ABOUT WORDFAST 

Overview 

Wordfast is a java-based translation and editing application designed to improve the way in which 

translators work. It presents translators with a collaborative environment where translation 

memory (TM) files can be accessed quickly and efficiently. Wordfast is a flexible application that 

can work with desktop TM files or interact directly with a powerful TM server application. It can 

also operate as a stand-alone tool to supplement existing translation workflows. 

Key advantages 

The key advantages of Wordfast are as follows: 

• TM compatibility: Tabular TM format allows for simple integration of Trados, SDLX or 

Déjà Vu TM files. 

• Format flexibility: Native format is TXML, an XML-based pivot format. Filters exist for 

DOC, PPT, HTML, MIF, INX, JSP and RC files. 

• Collaborative environment: Users can interact with TM Server and share translation 

memory assets in real-time. 

• Automated editing: Multi-lingual spell checkers and terminology recognition improves the 

speed and accuracy in the review process. 

• Administrative security: Managers can assign specific rights and privileges to individual 

translators or linguistic teams.  

Wordfast provides an intuitive, collaborative environment where translators can deliver higher 

quality in-language content with greater consistency and efficiency. 

Project Manager plug-in workflow 

Find below the workflow diagram for PM plug-in: 
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Note: The Extract frequents option is available in the Wordfast Professional Plus version only. 

TXML editor workflow 

Find below the workflow diagram for TXML editor: 
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GETTING STARTED WITH WORDFAST 
This section includes basic information that will help you get started with Wordfast.  

Opening Wordfast 

To open Wordfast, you have two options: 

Double-click the Wordfast shortcut on your desktop 

Or 

Go to C:\ > Program Files > Wordfast. 

The Wordfast homepage appears. 

 

Wordfast homepage 

The Wordfast homepage is the work space for project managers and translators to work on 

translation projects. The homepage directs you to two perspectives: 

• PM perspective 

• TXML editor perspective 
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PM perspective 

Find below a sample PM perspective screenshot: 

 

Find below the description for the various components of the PM perspective: 

Number Use to... 

 
PM 

perspective 

icon 

view the PM perspective. The PM perspective is the 

workspace for project managers to process files before 

and after translation. Go to Using PM plug-in for more 

information. 

 
Analyze tab analyze files for translation against a TM to leverage 

reusable content and pre-translate files. Go to Analyzing 

files for more information. 

 
Extract 

frequents 

tab 

extract recurring segments in the files. Go to Extracting 

frequents for more information. 

 

Note: The Extract frequents option is available in the 

Wordfast Professional Plus version only. 

 
Cleanup tab cleanup the file and update the TM after translation is 
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Number Use to... 

complete. Go to Cleaning up for more information. 

 
TM 

Preferences 

create or open a translation memory. 

TXML editor perspective 

Find below a sample TXML editor perspective screenshot: 

 

Find below the description for the various components of the TXML editor perspective: 

Number Use to... 

 
Title bar view the project name. 

 
Menu bar carry out all the functions, some of which are also 

included in the tool bar. Go to TXML editor menu 

options for more information. 

 
Tool bar quickly complete common functions. You can rollover 

the shortcut icons to see its function. 

 
TXML view the TXML editor perspective. The TXML editor 
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Number Use to... 

perspective 

icon 

perspective is the workspace for managing translation 

projects. This perspective allows you to translate files by 

leveraging translation memory and terminology. Go to 

Managing projects for more information. 

 
Main 

translation 

window 

translate a file. This is the work space for translating 

files. Go to Translating in a project for more information. 

 
TM Lookup 

window 

view TM leverage results and context searching. You 

can either search for a term or a phrase and the source 

and target segments appear in a table format. Go to 

Using TM Lookup window for more information. 

 
Txml 

Context 

view the TXML context of the currently open file. Go to 

Viewing TXML Context for more information. 

  
Outline 

window 

quickly navigate a file from one source segment to 

another. Go to Using Outline window for more 

information. 

 

 

 

 

 

 

 

14 



 

INSTALLING AND ACTIVATING WORDFAST 
To install Wordfast: 

1. Download the Wordfast installer from the webpage 

http://www.wordfast.com/store_download.html to your PC. 

2. Run the installer. 

The Wordfast Demo Mode appears. 
Note: Wordfast requires a Java JRE to be installed on your PC. During installation, if 

Java JRE does not exist, it will be installed for you. If it exists, then Wordfast will refer to it 

when running. 

In the Demo Mode, you can view and test all the functions of the software. You can 

purchase a Wordfast license from the webpage 

http://www.wordfast.com/store_download.html.  

If you do not purchase a license, you are limited to storing up to 500 translation units in 

your translation memories. 

To activate a Wordfast license:  

1. Purchase a Wordfast license from the webpage 

http://www.wordfast.com/store_download.html. 

The license file is sent to you via email. 

2. Save the license file to a known location, preferably C:\Program files\Wordfast. 

3. Open the Wordfast Demo Mode. 

4. Click Help > License Management. 
The Activation dialog box appears. 

5. Click License Manager. 

6. Select (Re-)Install a license certificate and click Next. 

7. Browse and navigate to C:\Program files\Wordfast and select the license file. 

8. Click Next twice and then Finish. 

9. Restart Wordfast. 

Your license is active. If you have any problems with the license and require support, 

please log into the Wordfast support hotline at www.wordfast.com. 
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USING PM PLUG-IN 
The Project Manager plug-in includes tasks that prepare files for translation. The preparation 

process includes the following tasks: 

• Receiving files and rules 

• Setting up formats 

• Analyzing files 

• Extracting frequents 

• Cleaning up and updating translation memory 

Receiving files and conversion rules 

This is the first step towards preparing files for translation. Find below a brief description of files 

and conversion rules: 

• Files: These are received from clients for translation. They may be in any format, such as 

DOC, XLS, PPT, INX, HTML, JSP and so on. When you open any one these files in 

Wordfast, it is automatically converted to TXML. 

• Conversion rules: These rules are required to convert XML files to TXML. The rules file is 

provided to you by the client. 

Setting up formats 

A format defines the working parameters for different types of files received for translation. A 

format can be selected from the available list or a new format created. Please note that the 

process to add MS Excel files is different from the other file formats. Find below the procedures 

for the following tasks: 

• Viewing default file formats 

• Adding new file formats  

• Adding an Excel file format 

VIEWING DEFAULT FILE FORMATS 
A number of format filters are pre-configured for your convenience. For example, if you choose 

the Default Java Properties Filter, the Encoding UTF-8 is automatically selected. 
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To view a default file format: 

1. Open Wordfast and click .  

The PM perspective appears. 

2. Click Edit > Preferences > Translations > Filters > Format. 
The Formats dialog box appears. The default formats appear in the Available formats 

box.  
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3. Select a default format of your choice. For example, if you select Default HTML Filter, the 

options for HTML files appear in the Options box as shown below. 

 

4. If required, you can modify the default options. 

5. Click Apply and OK. 

The default format is modified 

ADDING NEW FILE FORMATS 
If the format filter of your choice is not available in the default option, you can add a new format. 

For example, for XML and Excel format filters you will need to provide additional information. This 

section describes the following: 

To add an XML format: 

1. Follow steps 1 and 2 from Viewing default file formats. 

The Formats dialog box appears. The default formats appear in the Available formats 

box. 
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2. Click New. 

The New Format dialog box appears. 

 
3. Select the XML Filter Type and click OK. 

The New XML Filter appears in the Available Formats box. 

 
4. Select the Filter and click Rename, to change the filter name. 
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5. Select the Encoding as UTF-8. 

6. Browse and select the Conversion rules file. 
Note: The conversion rules file includes commands describing the content to be 

translated in the XML files. Find below an example rules file. 

 

7. Click Apply and OK. 

The new XML format is set up. 

ADDING AN EXCEL F ILE FORMAT 
To add an Excel file format: 

1. Follow steps 1 and 2 from Viewing default file formats.  

The Formats dialog box appears. The default formats appear in the Available formats 

box. 
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2. Select Format Type as Default Excel Filter. 

The Excel Filter options appear. 

 

3. Click Setup. 

The Choose Excel file... dialog box appears. 
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4. Select an Excel file and click Open. 

The Excel column selection wizard Instructions page appears. 

  

5. Read the instructions carefully and click Next. 
The Select wizard type page appears. 
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6. Select the wizard type. You have two options: 

• Simple: selects all rows with content for translation 

• Advanced: allows you to choose the columns for translation. It also creates a 

Target column where the translated text will appear. 

Simple wizard 

To run the Simple wizard: 

1. Follow steps 1 to 7 from Adding an Excel file format. 

2. Select Simple wizard and click Next. 
The Preview page appears. 

 

3. The content in the Preview page is selected for translation. 

The Preview page models an Excel file. There are tabs corresponding to each Excel 

sheet. Each tab contains the following: 

• Number of preview rows drop down list: to choose the number of rows to be 

viewed 

• Use header check box: select checkbox, if the header row should not be 

translated 
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• Table with the Excel sheet contents: select any row that should not be 

translated.  

4. Click Finish. 

The configuration and sample file path appears in the Formats Options box as shown in 

the screenshot below. 

 

5. Click Apply and OK. 

An Excel file format is set up. 
Note: You can now directly open Excel files of this type. While opening files you must 

choose the correct filter, when prompted. You can also rename the filter using the 

Rename button. 

Advanced wizard 

To run the Advanced wizard: 

1. Follow steps 1 to 7 from Adding an Excel file format. 

2. Select Advanced wizard and click Next. 
The Preview page appears. 
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3. The Preview page models an Excel file. There are tabs corresponding to each Excel 

sheet. Each tab contains the following: 

• Number of preview rows drop down list: to choose the number of rows to be 

viewed 

• Use header check box: select checkbox, if the header row should not be 

translated 

• Table with the Excel sheet contents: select any row that should not be 

translated.  
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4. Click Next. 
The Selection page appears. 

 

5. In the Translate column, select the columns for translation. 

The corresponding Column name appears in the Target column as shown in the 

screenshot below. 
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Note: The Target column includes names of columns where the translated text will 

appear.  

6. Click Next. 
The Regular expression page appears. 

 

7. Enter a Regular Expression for the Excel analysis. 
Note: A regular expression provides a pattern to markup any embedded HTML tags or 

variables in a column as placeables.  

8. Click Finish. 

The configuration and sample file path appears in the Formats Options box as shown in 

the screenshot below. 
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9. Click Apply and OK. 

An Excel file format is set up. 
Note: You can now directly open Excel files of this type. While opening files you must 

choose the correct filter, when prompted. You can also rename the filter using the 

Rename button. 

Analyzing files 

In the Analyzing files process, files for translation are analyzed against a translation memory to 

leverage reusable content and pre-translate files. This process can greatly improve efficiency and 

reduce time and effort spent on translation. Find below the procedures for the following tasks: 

• Selecting Analysis output option 

• Analyzing files 
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SELECTING ANALYSIS OUTPUT OPTION 
When a file is analyzed, an analysis output is generated in the same folder as the source files. 

The analysis output is the pretranslated TXML file. The analysis output options allow you to 

choose whether the pretranslated TXML file should be renamed to add the language suffix or 

placed in a separate folder with a language suffix or both. 

To select analysis output option: 

1. Open Wordfast and click .  

The PM perspective appears. 

2. Click Edit > Preferences > Translations > PM Plug-in. 

The Preferences (Filtered) PM Plug-in dialog box appears. 

  

3. Select a condition to be followed when analyzing files. The options are as follows: 

Select to... 

Add language suffix add the language code (for example ES_MX) as a 
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Select to... 

suffix to the analysis output file. An example 

screenshot of the source folder and the source and 

analysis output file is given below. 

 

 

Subfolder creation place the analysis output file within a subfolder. An 

example screenshot of the source and analysis 

output folder and file is given below. 

 

 

Subfolder creation with 

language suffix 

place the analysis output file within a subfolder. The 

subfolder and analysis output file will also include the 

language code as suffix. An example screenshot of 

the analysis output folder and file is given below. 

 

 

ANALYZING FILES 
To analyze files: 

1. Open Wordfast and click .  

The PM perspective appears 
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2. Click Analyze. 

The Analyze window appears. 

 

3. Select files from the available list or click , to browse and add files. 

The Browse For Folder dialog box appears. 
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4. Select the folder with the files and click OK. 

The Choose Format dialog box appears. 

  

5. Select Add files from subfolders checkbox if you want to add all files within a folder, 

including the files in the sub folders. 

6. Select the file Format.  
The file Extension appears automatically. 

7. Click OK. 

The file names appear. 

 

8. Click + to open the folder and select specific files. 

9. Select one or more translation memories for analyzing the files.  
Note: You will need to add at least one TM before analyzing files. To add a local or 

remote TM, click TM Preferences. Go to Creating or opening a TM for more information.  
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10. Select Pretranslate and enter the percentage of matches you wish to accept for 

pretranslation. 
Note: This is an optional step. The percentage defines the minimum leverage required to 

pre-translate a specific segment. 

You can also specify the analysis output option. For more information, refer Selecting 

Analysis output option.  

11. Select format for the output report. You have two options: 

• Output report as comma-separated format: Select this option and click Browse 

to select a location and provide a file name as shown in the screenshot below. 

 

Click Save, to save the CSV file. The Analyze window appears with the location 

of the CSV file as shown in the screenshot below. 

  

• Report format: Select this option to view the output report on-screen  

12. Click Analyze. 

The analyzed TXML files are saved in the same folder as the source files. According to 

the output report format, either a CSV file is saved at the chosen location or the Analysis 
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and translation report appears as shown below. 

 

Extracting frequents 

In the Extracting frequents process, repetitive source segments are extracted from the files for 

translation. Extracting frequents helps reduce the total number of segments to be translated. 

Note: The Extract frequents option is available in Wordfast Professional Plus version only. 

To extract frequents: 

1. Open Wordfast and click .  

The PM perspective appears 
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2. Click Extract. 
The Extract window appears. 

 

3. Select files from the available list or click , to browse and add files. 

The Browse For Folder dialog box appears. 

  

4. Select the folder with the files and click OK. 

The following confirmation message appears. 
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Note: Ensure that the original source file is at the same location as the TXML file and that 

they have the same file name.   

5. Click Yes if you want to add files recursively. This ensures that all files within a folder, 

including the files in the sub folders are added. 

The file names appear. 

 

6. Select the files from which you want to extract frequents. 
Note: Ensure all files selected or added are TXML files.  

7. Click  and select a location for saving the extracted segment and enter a filename 
prefix that is easily identifiable. 

8. Enter maximum number of segments per file. 

9. Enter minimum number of repetitions for a segment that you want to extract. 
Note: The number signifies the minimum number of times a segment must be repeated in 

the set of files to be extracted. For example, if this value is 1, Wordfast will extract one 

unique occurrence of all segments that appear once or more.  

10. Click Extract frequents. 

The repetitive segments are extracted and saved at the location provided. 
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Note: The TXML files with extracted frequent segments are sent to the translator for 

translation. After translated files are received from the translators, they are cleaned up 

and saved into the TM. The TM is then applied to the original TXML files, to complete the 

translation process. 

Cleaning up and updating translation memory 

After files are translated by the translator, they are sent back to the project manager. The PM 

then completes the final step of cleaning up the files and updating the TM. Cleaning up is an 

automated process, where the source segments are removed and the files are restored to their 

original format.  

To clean up and update TM: 

1. Open Wordfast and click .  

The PM perspective appears 

2. Click Cleanup. 

The Cleanup window appears. 
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3. Select files from the available list or click , to browse for files. 

The Browse For Folder dialog box appears. 

  

4. Select the folder with the files and click OK. 

The following confirmation message appears. 

 
Note: Ensure that the original source file is at the same location and TXML file and that 

your TXML file has the same name as the source file.   

5. Click Yes if you want to add files recursively. This ensures that all files within a folder, 

including the files in the sub folders are added. 
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The files for cleanup appear. 

 

6. Click + to open the file folder and select specific files. 

7. Select Update TM check box for updating files to a TM. (Optional).  

8. Select the translation memory.  
Note: You will need to add at least one TM before analyzing files. To add a local or 

remote TM, click TM Preferences. Go to Creating or opening a TM for more 

information.   

9. Select an Update option. The options are as follows: 

Select to... 

Overwrite existing TU 

(default) 

overwrite the existing translation unit. 

Do not overwrite TU not overwrite existing translation unit. 

Overwrite if attributes are 

identical 

overwrite the existing translation unit only if custom 

attributes for new and existing translation units are 

identical. 

Do not add to TM not add to the translation memory.  

10. Select Add Attributes checkbox, to enter custom attributes for the translation unit. 

11. Select Add file name as attribute, to add file name as a custom attribute. 

12. Select format for the output report. You have two options: 

• Comma-separated format: Select this option and click Browse to select a 

location and provide a file name 
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• Report format: Select this option to view the output report on-screen  

13. Click Cleanup.  

A Cleanup report appears. 
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TXML EDITOR MENU OPTIONS 
The Wordfast basic menu options are as follows: 

• File 

• Edit 

• Translation Memory 

• Terminology 

• Window 

• Help 

File 

The options in the File menu are as follows: 

Use to... 

Create Project... create a new project. 

Open Project... open an existing project. 

Open... (Ctrl+O) open a new file. 

Note: When you browse your PC, only the file 

types listed in your File Associations setup 

(Window > System Preferences > General > 
Editors > File Associations) will appear. 

Close (Ctrl+W) 

 

close the currently open file. If there are unsaved 

changes, a warning message appears asking if 

you want to save the changes before closing. 

Close All 

(Ctrl+Shift+W) 

close all open files. If there are any unsaved 

changes, a warning message appears asking if 

you want to save the changes before closing. 

Save (Ctrl+S) save the currently open file. 

Save translated 

file 

save PPT, XLS or DOC files.  

Note: This menu option is activated only when 

PPT, XLS or DOC files are saved. 

Save As... save and rename the currently open file. 
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Use to... 

Save All 

(Ctrl+Shift+S) 

save all the currently open files. 

Revert revert the file to the state since it was opened, or 

since it was last saved, whichever is most recent. 

Print print the file that is currently open. 

Properties view information related to the currently open file, 

such as the original file format. 

Exit exit Wordfast. If there are any files open with 

unsaved changes, a warning message appears 

asking if you want to save the changes before 

exiting. 

Edit 

The options in the Edit menu are as follows: 

Use to... 

Undo (Ctrl+Z) undo most recently entered text or performed 

function. 

Redo (Ctrl-Y) redo most recently deleted text or re-perform 

undone function. 

Cut (Ctrl-X) cut the selected text. This action can be performed 

only in the target segment. 

Copy (Ctrl-C) copy the selected text.  

Paste (Ctrl-V) paste the copied text at the location of your cursor. 

This action can be performed only in the target 

segment. 

Select All (Ctrl-A) select all the text in the main Translation window. 

Find/Replace 

(Ctrl-F) 

search the current file for text and replace that text 

with another text. This action can be performed 

only in the target segment. 

Spell Check (F7) check spelling.  
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Use to... 

Copy Context copy the TM lookup target segment into the file 

target segment. 

Preferences set translation, translation memory, penalties and 

terminology preferences. 

Translation Memory 

The options in the Translation Memory menu are as follows: 

Use to... 

New/Select TM create or select a translation memory. 

Next Segment  

(Alt+Down) 

navigate to the next segment. This action 

automatically saves the segment to the TM, if 

you have edited the translation. 

Previous Segment 

(Alt+Up) 

navigate to the previous segment. This action 

automatically saves the segment to the TM, if 

you have edited the translation. 

Current Segment 

Leverage (Alt+Space) 

leverage the TM for the current source 

segment. 

Clear Target Segment clear the text in the target segment. 

Translate Until Fuzzy 

(Ctrl+Alt+F) 

translate the source segments until there is a 

fuzzy match. 

Translate Until No 

Match  

(Ctrl+Shift+PageDown) 

translate the source segments until there is 

no match. 

Translate All 

(Ctrl+Shift+End) 

translate all source segments. 

Copy Source 

(Alt+Insert) 

copy the text from the source segment into 

the target segment. 

Expand Segment 

 

combine the currently selected source 

segment with the next segment.  

 

Note: This function can be accomplished only 
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Use to... 

with segments in the same paragraph. 

Segments that have a paragraph break 

between them cannot be combined. 

Shrink Segment split the source segment into two segments, 

at the location of the cursor.  

Confirm/Unconfirm 

Segment 

mark a segment for future reference. 

Commit to TM  

(Alt+End) 

save the translated segments to the TM and 

close the file. This action is typically carried 

out when you have completed translation. 

Previous Placeable  

(Ctrl+Alt+Left) 

select the previous placeable in the source 

segment. The selected placeable will be 

highlighted in red by default. 

Remove Placeable  

(Ctrl+Alt+Up) 

delete the currently selected placeable. 

Copy Placeable  

(Ctrl+Alt+Down) 

copy the currently selected placeable into the 

target segment at the location of the cursor. 

Next Placeable  

(Ctrl+Alt+Right) 

select the next placeable in the source 

segment. The selected placeable will be 

highlighted in red by default. 

TM Lookup 

 

look up the selected source text in the 

translation memory. This action leverages all 

segments that include that text. 

Analyze analyze the file for translation against a TM to 

leverage reusable content and pre-translate 

content. 

Terminology 

The options in the Terminology menu are as follows: 

Use to... 

New/Select 

Terminology 

create or select a terminology. 
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Use to... 

Add Term add a terminology to the terminology list. 

Previous Term 

(Ctrl+Alt+8) 

navigate to the previous terminology in the 

source segments. 

Copy Term 

(Ctrl+Alt+0) 

copy the selected terminology. 

Next Term 

(Ctrl+Alt+9) 

navigate to the next terminology in the source 

segments. 

Edit modify the terminology list. 

Import import a terminology list to the open project. 

Export export a terminology list to a location, either on 

your computer or a common server. 

Window 

The options in the Window menu are as follows: 

Use to... 

Show View preview a TXML file in Word or view the source 

context. This option also allows you to add or 

remove the Outline, TM Lookup and TXML 

Context view. 

System Options view and change the system preferences. 

Help 

The options in the Help menu are as follows: 

Use to... 

Online Help view the Wordfast help. 

Bug Report... view or send the error log. 

Wordfast Updates find and install new releases and manage 

configurations. 

Key Assist 

(Ctrl+Shift+L) 

view all Wordfast functions and keyboard 

shortcuts.  
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Use to... 

License 

Management 

complete activation of Wordfast and manage 

license. 

About Wordfast view plug-in and configuration details of 

Wordfast. 
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MANAGING PROJECTS 
Translation projects can be managed both by project managers and translators. Managing a 

project includes the following tasks: 

• Creating or opening a project 

• Creating or opening a translation memory 

• Importing and exporting terminology lists 

• Defining penalties 

• Defining color codes 

• Enabling spell check 

• Translating in a project 

• Deleting a project 

Creating or opening a project 

In Wordfast, it is necessary to create a project before translating a file. You can open a TXML file 

for translation only if a project is created or opened. The project is a working environment that 

defines settings for the source and target language, translation memory, glossary and other user 

information. Find below the procedures for the following tasks: 

• Creating a project 

• Opening a project 

CREATING A PROJECT 
To create a project: 

1. Open Wordfast and click . 

The TXML perspective appears. 
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2. Click File > Create Project. 
The Create Project dialog box appears. 

  

3. Enter a unique Project name. 
Note: A unique project name enables differentiation. Naming the project according to the 

client name is a good practice. If a unique name is not given, an error message appears 

at the bottom of the dialog box.  

4. Select Source and Target language. 
Note: It is important to select the correct source and target languages. If either of them is 

incorrect, Wordfast will not allow you to open files for translation. The languages that you 

provide now will be the default language selection for all project files.  

5. Click OK. 

The Open Project dialog box appears. The project name appears in the Project List and 
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the project properties appear at the bottom of the dialog box. 

  

6. Select project name and click OK. 

The Preferences (Filtered) dialog box appears. 

 
The Preferences (Filtered ) dialog box is used for the following tasks: 
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• Selecting translation memory settings. Go to Selecting translation memory settings 

for more information. 

• Creating or opening translation memory. Go to Creating or opening translation 

memory for more information. 

• Importing, exporting, adding, editing and deleting terminology. Go to Importing and 

exporting terminology and Working with terminology for more information. 

• Defining penalties. Go to Defining penalties for more information. 

• Defining color codes. Go to Defining color codes for more information. 

• Enabling spell check. Go to Enabling spell check for more information. 

OPENING A PROJECT 
To open a project: 

1. Open Wordfast and click . 

The TXML perspective appears. 

2. Click File > Open Project. 
The Open Project dialog box appears. The project names appear in the Project list and 

the project properties appear at the bottom of the dialog box. 

3. Select a project name and click OK. 

The Wordfast screen appears with the project name on the title bar and the source and 
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target languages at the bottom of the screen. 

 

Creating or opening a TM 

Translation memory (TM) is designed to provide maximum content re-use and facilitate 

collaboration between globally distributed localization resources. Translators can leverage 

reusable content in two ways: 

• Local TM: The local TM is located in your system and can only be accessed and updated 

by you.    

• Remote TM: The remote TM is located on a server that can be accessed by several 

translators at the same time. The translators can leverage the available content and also 

update the TM with new reusable content. 

Find below the procedures for the following tasks: 

• Selecting translation memory settings 

• Creating a local TM 

• Opening a local TM 

• Creating or opening a remote TM 
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SELECTING TRANSLATION MEMORY SETTINGS 
To select translation memory settings: 

1. Open Wordfast and click . 

The TXML perspective appears. 

2. Follow steps 1 to 6 from Creating a project 

Or 

Click Translation Memory > New/Select. 

The Preferences (Filtered) dialog box appears. 

3. In the left pane, click Translation Memory. 

The Translation Memory dialog box appears. 

 

4. Select Copy source on no match checkbox, to copy the source to the target segment, if 

there is no match when the TM is leveraged. 

5. Enter the Fuzzy Match Threshold in (%). 
Note: This value signifies the TM leverage percentage limit for a fuzzy match. For 

example, if you enter a value of 75%, the tool will mark all the translations which are 

leveraged below 75% match as a 'No match' segment.  
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6. Select a condition to be followed when editing an existing Translation Unit. The options 

are as follows: 

Select to... 

Add to TM by 

overwriting the existing 

TU (default) 

overwrite the existing translation unit. This option is 

selected by default. 

Add TM; overwrite 

existing TU if attributes 

are identical 

overwrite the existing translation unit only if custom 

attributes for new and existing TU are identical. 

Add to TM: do not 

overwrite existing TU 

add to translation memory and not overwrite existing 

TU 

Do not add to TM not update the TM. 

7. Select Mark all segments as unconfirmed checkbox, to mark all target segments as 

unconfirmed. For more information, refer Confirming or Unconfirming segments. 

8. Click Apply and OK. 

The translation memory properties for the project are set up.  

CREATING A LOCAL TM 
To create a local TM: 

1. Follow steps 1 to 2 from section Selecting translation memory settings. 

55 



Wordfast Professional Plus User Manual 

2. In the left pane, select Translation Memory > Local. 
The Translation Memory - Local dialog box appears. 

 

3. Click New. 

The New Local TM dialog box appears. 

  

4. Enter or browse the location for the local TM. 

5. Enter a file name for the new local TM and click Save. 
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6. Enter a Symbolic name for the Local TM. 
Note: Ensure that the name is unique and easily recognizable. If a unique name is not 

given, an error message appears at the bottom of the dialog box.  

7. Select Source and Target language. 
Note: The default source and target languages are the same as the currently open 

project. Ensure that the selected TM and project have the same language pair assigned. 

If either of them is incorrect, the TM will not be leveraged in the project.  

8. Click OK. 

The newly created local TM name appears in the Local TM List and the properties appear 

at the bottom of the dialog box. 

 

9. Select Selected check box, to use the newly created local TM during translation.  

10. Select Read only check box, if you do not want to update the local TM. (Optional) 

11. Click  or  to prioritize newly created or available local TMs. 
Note: Prioritizing TMs will ensure that the first TM in the list is leveraged first, followed by 

the remaining TMs.  
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12. Click Apply and OK. 

A new local TM is created for the project.  

OPENING A LOCAL TM 
To open a local TM: 

1. Follow steps 1 to 2 from section Creating a local TM. 

2. Click Open. 

The Open Local TM dialog box appears. 

  

3. Enter or browse the location of the local TM. 

4. Select a local TM file and click Save. 
Note: Ensure that the correct local TM is selected. The local TM file must have a correct 

header, which typically includes the creation date, user ID, source and target language 

and so on. If an error occurs, please log into the Wordfast support hotline at 

www.wordfast.com.  

5. Follow steps 4 to 10 from section Creating a Local TM. 

An existing local TM is selected for the project.  

Creating or opening a remote TM 

To create or open a remote TM: 

1. Follow steps 1 to 2 from section Selecting translation memory settings. 
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2. In the left pane, select Translation Memory > Remote. 

The Translation Memory - Remote dialog box appears. 

 

3. Click New or Open. 

The New or Open Remote TM dialog box appears. 
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4. Enter the Remote TM Address and Port details. 

5. Enter the Username and Password to connect to the Remote TM. 
Note: When you provide the Remote TM information, the URL appears automatically. 

The remote TM URL and login details are provided to you by the client, if they are using a 

Wordfast TM server.  

6. After entering all Remote TM information, click Test. 
Connection to the remote TM is established and a message appears. 

7. Modify the Symbolic name for the Remote TM, if required. 
Note: The default symbolic name is a combination of the user name, address and port 

details.  

8. Enter Workgroup ID and Search Depth. (Optional) 
Note: The Workgroup ID is a 10 digit number and is provided to you by the Wordfast 

administrator. If a Workgroup ID is not entered, you can only read from the remote TM. 

The Workgroup ID is required if you need to update the remote TM. 

Ensure that the user name is unique and easily recognizable. 

Search depth signifies the number of results that can be viewed for a particular search. 

For example, if you are looking for segments containing the word "hotel", only the first 

200 segments in the remote TM containing that word will appear.  

9. Click OK. 

The newly created or opened remote TM name appears in the Remote TM List and the 

properties appear at the bottom of the dialog box. 
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10. Select Selected check box, to use the new remote TM during translation.  

11. Select Read only check box, if you do not want to update the remote TM. (Optional) 

12. Click  or  to prioritize newly created or available remote TMs. 

13. Click Apply and OK. 

A new or existing remote TM is created or opened for the project. 

Importing and exporting terminology lists 

A terminology list (or glossary), is a list of source terms and their preferred translations. For 

example, a terminology list could include information as follows: 

Source  Target 

translation memory mémoire de traduction 

translation unit  unité de traduction 

data transfer rate taux de transfert de données 

International Translators Federation Fédération Internationale des 

Traducteurs 

The terminology list is stored as a tab-delimited list of source and target terms on your computer 

or a common server. To use a terminology list, you need to import it to Wordfast. After completing 

a translation project you also have an option to add new terms and export the term list to your 

computer or a common server. Find below the procedures for the following tasks: 

• Importing a terminology list 

• Exporting a terminology list 

IMPORTING A TERMINOLOGY LIST 
To import a terminology list: 

1. Open Wordfast and click . 

The TXML perspective appears. 
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2. Click Terminology > Import. 
The Import terminology dialog box appears. 

  

3. Enter or browse for the terminology file. 

4. Choose File type. You have two options: 

• Tab delimited: a TXT file 

• TBX: an XML file 

5. Next, you have two options: 

• Select Create new terminology, if you are importing the first terminology file for 

the project. 

• Select Import into existing terminology, if you have already imported a 

terminology file and want to combine both the files. 

Creating new terminology 

To create a new terminology list: 

1. Follow steps 1 to 4 from Importing a terminology list. 

2. Select Create new terminology. 
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3. Click OK. 

The Create new Terminology dialog box appears. 

  

4. Enter Symbolic name, Source language and Target language. 

5. Click OK. 

A Terminology import message appears confirming the number of terms imported. 

6. Click OK. 

A new terminology file is created. 

Import into existing terminology 

To import a new terminology list into an existing terminology list: 

1. Follow steps 1 to 4 from Importing a terminology list. 
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2. Select Import into existing terminology. 

The Import into existing terminology option is activated. 

  

3. Select the Existing terminology list for the open project. 

4. Select an action, if there is an overlap between the existing and new terminology list. 

5. Select Clear before import, if you want to clear all terms in the existing terminology list. 

6. Click OK. 

The Terminology import report dialog box appears. This describes the number of terms 

that will be imported. 

7. Click OK. 

The new terminology file is imported and a message appears. The terminology list 

appears as a separate tab. 

EXPORTING A TERMINOLOGY LIST 
To export a terminology list: 

1. Open Wordfast and click . 

The TXML perspective appears. 

64 



Managing projects 

2. Click Terminology > Export. 
The Export terminology dialog box appears. 

  

3. Select Terminology name. 

4. Enter or browse the location for the terminology file. 

5. Select File type. You have two options: 

• Tab delimited: a TXT file 

• TBX: an XML file 

The Terminology export report dialog box appears. This describes the number of 

terms that will be imported. 

6. Click OK. 

The terminology list is exported and saved at the specified location. 

Defining penalties 

Penalties are defined to maintain high quality of the content leveraged from translation memory. A 

value is assigned to each of the penalties, which are taken into account to calculate the 

translation score. This score is used to differentiate between golden or 100 %, fuzzy and no 

match.  

To define penalties: 

1. Open Wordfast and click . 

The TXML perspective appears. 

2. Click Edit > Preferences > Translations > Translation Memory > Penalties. 

The Preferences (Filtered) Penalties dialog box appears. 
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3. Enter values for penalties. Find below the list of penalties and description: 

Penalty Description 

Case penalizes different case in letters. 

Non Literal penalization is for punctuations, space, special characters 

like apostrophes, dashes, quotes and so on 

Tag penalizes different placeables. 

Attribute penalizes if attributes differ. 

Private TU penalizes workgroup Translation Unit (TU). 
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Penalty Description 

Public TU penalizes non-workgroup TU. 

Local TM penalizes TU from local desktop copy. 

Align penalizes TUs coming from an alignment. 

Machine 

Translation 

penalizes TUs coming from MT. 

Multiple 

Translations 

penalizes TUs if there are duplicates within the TM with 

different translations. 

Match file names consider filename as an attribute for penalization. 

Custom 

Attributes 

consider this attribute name for penalization. 

4. Click Apply and OK. 

Defining color codes 

The color codes are used to differentiate between different types of content in the TXML editor 

workspace. 

To define color codes: 

1. Open Wordfast and click . 

The TXML perspective appears. 

2. Click Edit > Preferences > Translations > Translation Memory > Colors. 

The Preferences (Filtered) Colors dialog box appears. This displays the default colors 
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assigned to different content types. 

 

3. If you want to change the default color for any of the content types, click the colored box.  

For example, click the colored box next to Tag color. 

A color palette appears. 
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4. Select a color, for example, purple and click OK.  

The color code for the selected content changes from blue to purple. 

 

Enabling spell check 

Enabling the spell check option is a good practice to ensure high quality.  

To enable spell check: 

1. Open Wordfast and click . 

The TXML perspective appears. 
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2. Click Edit > Preferences > Spelling. 

The Preferences (Filtered) Spelling dialog appears. 

 

3. Select Enable spell checking checkbox. 

The Hunspell spellcheck engine is automatically selected. 

4. Select Check Spelling as you type checkbox. (Optional) 

5. Click Apply and OK. 

The Spell check option is enabled. 
Note: To use spell check, click Edit > Spell Check or press F7. The option for choosing 

spell check languages is available during installation. 

Translating in a project 

After you have completed the initial steps of creating project, opening translation memory, 

importing terminology and defining penalties and colors, the Wordfast workspace is ready to be 

used for translation. The translation process broadly includes the following tasks: 
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• Opening a file 

• Translating a file 

• Leveraging repetitive content 

• Working with translation memory 

• Working with terminology 

• Working with placeables 

• Using Transcheck 

• Confirming or Unconfirming segments 

• Using Outline window 

• Viewing TXML Context 

• Saving and closing a file 

• Using shortcut icons 

OPENING A FILE 
To open a file for translation: 

1. Open Wordfast and click . 

The TXML perspective appears. 

2. Click File > Open, select file for translation and click Open.  
Or 

Left-click on the file, and drag and drop into the Translation window. 

The file appears in the Translation window. 
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Find below the description for the various components of the Wordfast workspace: 

Number Component Description 

 
File name The TXML file name appears here. You can 

open multiple files, which appear as tabs. 

 
Source 

segment 

The segment that requires translation 

appears here. 

 
Translation 

score 

The translation score, which is the 

percentage of match found in the TM 

appears here. 

 
Target 

segment 

The translated content is entered here by the 

translator. 

 
Views The TXML file can be viewed in two ways, as 

plain text and in a table format. 

 
TM Lookup 

window 

The TM leverage results appear here. You 

can also search the TM for a term or a 

phrase. Go to Using TM Lookup window for 

more information. 
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Number Component Description 

 
Txml 

Context 

view the TXML context of the currently open 

file. Go to Viewing TXML Context for more 

information. 

  
Outline 

window 

The color coded list of all source segments 

appears here. The colors signify the 

translation score. Go to Using Outline 

window for more information. 

TRANSLATING A FILE 
This section describes the steps for translating a TXML file when there are no TMs available for 

leverage. After entering the new translation for a file, you can save the translation to a new TM, 

which can be leveraged at a later stage. 

To translate a file: 

1. Follow the steps to open a file from section Opening a file. 

The file appears in the Translation window. The first translatable segment will appear in a 

blue background, and your cursor will be in the target segment by default. 

 
Note: The placeables in the source segment are marked in grey. For example, {ut1}. 
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These placeables should be either copied and pasted or typed into the target segment. 

They should not be edited or deleted.  

2. Type the target segment. 

The typed target segment will appear in a pink background as shown in the screenshot 

below. 

 

3. Select Translation Memory > Next Segment or click  or press Alt+Down. 

The typed target segment is saved to the TM and the cursor moves to the next segment. 
Note: If you need help creating or opening a TM, go to Creating or opening a TM. To 

update translation memory with new content, ensure the TM has the Read only check 

box clear and update options are selected. Go to Selecting translation memory settings 

for more information. 

Also note that, the TM will not be leveraged or updated if you press the Enter or Tab 

keys or if you click into another segment in the Translation window or the Outline 

window.  

4. After translating all the source segments, select Translation Memory > Commit to TM 

or click  or press Alt+End, to update the TM before closing the file. 
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LEVERAGING REPETITIVE CONTENT 
The leveraging repetitive content option can be used when there are repetitive segments in a file. 

For example, if there are multiple instances of the phrase "Our Process" then the translator needs 

to type the translation only once. The remaining segments are leveraged automatically. 

To leverage repetitive content: 

1. Follow the steps to open a file from section Opening a file. 

The file appears in the Translation window. The first translatable segment will appear in a 

blue background, and your cursor will be in the target segment by default. 

 
Note: There are three instances of the source segment "Our Process".  

2. Type the target segment for the first instance. 

The typed target segment will appear in a pink background as shown in the screenshot 
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below. 

 

3. Select Translation Memory > Next Segment or click  or press Alt+Down. 

The typed target segment is saved to the TM and the subsequent repetitive segments are 

leveraged. 
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Note: The remaining two instances of "Our Process" are translated automatically. 

WORKING WITH TRANSLATION MEMORY 
Translation memory (TM) is designed to provide maximum content re-use and facilitate 

collaboration between globally distributed localization resources. Find below the procedures for 

the following tasks: 

• Leveraging translation memory 

• Using TM Lookup window 

• Updating translation memory 

Leveraging translation memory 

To leverage translation memory: 

1. Follow the steps to open a file from section Opening a file. 

The file appears in the Translation window. The first translatable segment will be open, 
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and your cursor will be in the target segment by default. 

 

2. Select Translation Memory > Current Segment Leverage or click  or press 

Alt+Space. 
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The TM will be leveraged and the target segment appears. 

 

Translation memory default color representation 

Find below the list of default color representations for source and target segments in the 

Translation window: 

Color Representation 

Blue Source segment 

Yellow Fuzzy match 

Grey No match or NA 

Green 100% match 

Pink Segment modified since the 

original file was created 

Purple Segment modified and updated 

to translation memory 

Go to Defining color codes for more information. 

Using TM Lookup window  

The TM Lookup window is used to view TM leverage results and context searching. Find below 

the procedure for the following tasks: 
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• Viewing TM leverage results 

• Using TM lookup 

Viewing TM leverage results 

The TM Lookup window displays the leverage results for the current source segment. The results 

display an ID number, source and target segments, the translation score and the translation 

memory name. 

 

TM Lookup default color representation 

Find below the list of default color representations for source and target segments and translation 

score in the TM Lookup window: 

Color Representation 

Blue Source segment 

Yellow Fuzzy match 

Green 100% match 

Highlighted 

text 

Words or phrases that do not 

match the source segment 

Go to Defining color codes for more information. 

Using TM lookup 

TM lookup is a process that searches for specific source segment text in the translation memory. 

The results display source and target segments.  

To perform TM lookup: 

1. Enter a word or phrase in the TM Lookup text box. 

2. Click Find. 
Note: If you want matches that only have all the words in your phrase, use + signs 

between each word instead of spaces. If you use spaces in the search string, then results 

will show segments that have any of the words in them. 

Or 

1. Select a word or phrase in the source segment.  

80 



Managing projects 

2. Press Ctrl-Alt-L or . 

The source and target segments appear. 

 
Note: The words or phrases that match the searched context are highlighted. 

Updating translation memory 

To update translation memory with new content, ensure the TM has the Read only check box 

clear and update options are selected. Go to Creating or opening a translation memory and 

Selecting translation memory update settings for more information. 

When you navigate source segments by pressing Alt+Down or Alt+Up or clicking   or , 

segments are saved automatically to the TM.  

Note: If you have changed the target segment, and you navigate using other methods (i.e., 

clicking on other segments to navigate directly to them), a warning message appears asking if 

you want to save the target segment. 

WORKING WITH TERMINOLOGY 
Find below the procedures for the following tasks: 

• Leveraging a terminology list 

• Adding terminology 
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• Editing terminology 

Leveraging a terminology list 

To leverage a terminology list or glossary: 

1. Follow the steps to open a file from Opening a file. 

The file appears in the Translation window. If a term from the terminology list or glossary 

exists in the source segment, it will appear in red by default. 

  

2. Select Terminology > Previous term / Next term or click  or  or press Ctrl+Alt+8 
/ Ctrl+Alt+9. 

The terminology is highlighted and selected. 

3. In the target segment, place the cursor at the location where you want the translated 

terminology to appear. 

4. Select Terminology > Copy term or click  or Ctrl+Alt+0. 

The translated terminology appears in the target segment. 

 

Adding terminology 

To add terminology to a terminology list or glossary: 

1. Left-click and select a terminology in the source or target segment. 
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2. Click Terminology > Add term or click . 

The Add to Terminology dialog box appears. 

  

3. Enter Source, Target and Description of the terminology. 

4. Select the terminology list that you want to add the terminology to. 

5. Click OK. 

The new terminology is added. 

Editing terminology 

To edit terminology: 

1. Click Terminology > Edit. 
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2. Select the terminology list that you want to edit. 

The Terminology list appears. 

 

3. Double-click on the entry you want to modify. 

The Edit term dialog box appears. 

  

4. Enter the necessary changes and click Modify. 

The modified terminology appears in the terminology list. 
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WORKING WITH PLACEABLES 
A placeable is inline text that is not translatable. For example, HTML code within a sentence. 

Target segments should have the same placeables as the source segment, however depending 

on the language sometimes a placeable is not needed. If you try to save a target segment with 

missing placeables, a warning message appears. Find below an example of a source segment 

with two placeables: 

Please contact the hotel for further information at {ut1}info@companyname.com{ut2}. 

The {ut1} and {ut2} text strings represent placeables. 

Find below the procedures for the following tasks: 

• Viewing placeables 

• Copying placeables 

• Deleting placeables 

Viewing placeables 

To view placeables: 

1. Follow the steps to open a file from Opening a file. 

The file appears in the Translation window. If a placeable exists in the source segment, it 

will appear in gray by default.  

2. Place the mouse over the placeable. 

The actual text in the placeable appears. Find below an example of the popup for the 

{ut1} placeable. 

 

Copying placeables 

To copy placeables: 

1. Follow the steps to open a file from Opening a file. 

The file appears in the Translation window. If a placeable exists in the source segment, it 

will appear in gray by default. 

2. Select Translation Memory > Previous placeable / Next placeable or click  or  or 

press Ctrl+Alt+Left / Ctrl+Alt+Right. 
The placeable is highlighted in red and selected. 
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3. Place the cursor where you want the placeable in the target segment. 

4. Select Translation Memory > Copy placeable or click  or Ctrl+Alt+Down or type the 

characters of the placeable. 

The placeable appears in the target segment. 

 

Deleting placeables 

The placeable can be deleted only in the target segment. To delete placeables, place your cursor 

in the placeable's text and select Translation Memory > Remove placeable or click  or press 

Ctrl+Alt+Up.  

USING TRANSCHECK 
The Transcheck option verifies certain elements in the target segments and warns you about 

missing or incorrect text or variables. For example, if you do not insert a placeable or type 

incorrect text, a warning signal will appear before the target segment. You will be able to view the 

warning on mouse over. 

Find below the procedures for the following tasks: 

• Enabling Transcheck 

• Viewing Transcheck warning 

Enabling Transcheck 

To enable Transcheck: 

1. Open Wordfast and click . 

The TXML perspective appears. 

2. Click Edit > Preferences > Translations > Transcheck. 

The Transcheck dialog box appears. 
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3. Select Enable Transcheck checkbox. 

4. Click Apply and OK. 

The Transcheck option is enabled. 

Viewing Transcheck warning 

Note: The Transcheck warning can be viewed only in the Text mode. 

To view Transcheck warning: 

1. Follow the steps to open a file from section Opening a file. 

The file appears in the Translation window. 
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2. Type the target segment. 

A warning signal appears before the target segment as shown in the screenshot below. 

 

3. Place the mouse over the warning signal. 

The text in the warning appears as shown in the screenshot below. 

 
Note: The Transcheck warning appeared because the number 101 was incorrectly typed 

as 102. The warning signal disappears when the segment is corrected as shown in the 

screenshot below. 
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CONFIRMING OR UNCONFIRMING SEGMENTS 
The Confirm/Unconfirm Segment option allows the translator to mark a segment for future 

reference. For example, if the translator wants to check and confirm a segment after referring to 

some resources, he or she can mark the segment and revert to it at a later stage. 

To confirm or unconfirm a segment: 

1. Follow the steps to open a file from section Opening a file. 

The file appears in the Translation window. The first translatable segment will appear in a 

blue background, and your cursor will be in the target segment by default. 

1. Type or leverage the target segment from the translation memory. 

The target segment will appear. 

2. Click Translation Memory > Confirm/Unconfirm Segment or , to mark the 

segment. 

An '*' symbol appears next to the segment in the Outline window as shown in the 

screenshot below. 

 

Note: The '*' symbol will disappear only when you click Translation Memory > 

Confirm/Unconfirm Segment or  again to confirm the segment. 
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USING OUTLINE WINDOW 
The Outline window is used for source segment navigation. The source for each translatable 

segment is listed with color coded icons that represent the translation score. The segments that 

need to be confirmed are also marked by an asterisk (*) in the Outline window. Find below an 

example of an Outline window: 

 

Navigating using Outline window 

To view a source segment, in the Outline window, place the cursor on a source segment and left 

click. 

The source segment is selected and highlighted. 

Sorting segments 

To sort the source segments, click on the drop down list. 

The following options appear: 

 

Outline window default color representation 

Find below the list of default color representations for source and target segments in the 

Translation window: 
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Color Representation 

Yellow Fuzzy match 

Grey No match or NA 

Green 100% match 

Pink Segment modified since the 

original file was created 

Purple Segment modified and updated to 

translation memory 

Go to Defining color codes for more information. 

VIEWING TXML CONTEXT 
The TXML Context window is used to view the TXML context of the currently open file. You also 

have the option to view the XML Source. Find below an example of a TXML Context window: 

 

SAVING A FILE 
To save a file: 
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• Click File > Save or Ctrl+S, to save the currently open file. 

• Click File > Save translated file, to save PPT, XLS or DOC files. 

• Click File > Save As..., to save and rename the file. 

• Click File > Save All, to save all open files. 

CLOSING A FILE 
To close a file: 

• Click File > Close or click <icon>, to close the currently open file. 

• Click File > Close All, to close all open files. 
Note: If you close a file without saving the most recent changes, a warning message 

appears querying if you want to save the file.  

USING SHORTCUT ICONS 
Wordfast includes a number of shortcut icons that help you quickly complete common tasks. Find 

below a list of all the shortcut icons available in the TXML Editor and their functionality. 

Use to... 

 (Ctrl+O) 
open a new file. 

Note: When you browse your PC, only the file types 

listed in your File Associations setup (Window > 
System Preferences > General > Editors > File 
Associations) will appear. 

 (Ctrl+S) 
save the currently open file. 

 
preview the file in MS Word. 

 (Ctrl+Alt+8) 
navigate to the previous terminology in the source 

segments. 

 (Ctrl+Alt+0) 
copy the selected terminology. 

 (Ctrl+Alt+9) 
navigate to the next terminology in the source 

segments. 

 
modify the terminology list. 

 
add a terminology to the terminology list. 
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Use to... 

 
print the file that is currently open. 

 (Ctrl+Shift+O) 
create or select a translation memory. 

 (Alt+Down) 
navigate to the next segment. This action 

automatically saves the segment to the TM, if you 

have edited the translation. 

 (Alt+Up) 
navigate to the previous segment. This action 

automatically saves the segment to the TM, if you 

have edited the translation. 

 (Alt+Space) 
leverage the TM for the current source segment. 

 (Ctrl+Alt+F) 
translate the source segments until there is a fuzzy 

match. 

 
(Ctrl+Shift+PageDown) 

translate the source segments until there is no 

match. 

 (Ctrl+Shift+End) 
translate all source segments. 

 (Alt+Insert) 
copy the text from the source segment into the target 

segment. 

 (Alt+E) 
combine the currently selected source segment with 

the next segment.  

 

Note: This function can be accomplished only with 

segments in the same paragraph. Segments that 

have a paragraph break between them cannot be 

combined. 

 (Alt+S) split the source segment into two segments, at the 

location of the cursor. 

 mark a segment for future reference. 

 (Alt+End) 
save the translated segments to the TM and close 

the file. This action is typically carried out when you 

have completed translation. 
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Use to... 

 (Ctrl+Alt+Left) 
select the previous placeable in the source segment. 

The selected placeable will be highlighted in red by 

default. 

 (Ctrl+Alt+Up) 
delete the currently selected placeable. 

 (Ctrl+Alt+Down) 
copy the currently selected placeable into the target 

segment at the location of the cursor. 

 (Ctrl+Alt+Right) select the next placeable in the source segment. The 

selected placeable will be highlighted in red by 

default. 

 
analyze the file for translation against a TM to 

leverage reusable content and pre-translate content. 

 (Ctrl+Alt+L) 
look up the selected source text in the translation 

memory. This action leverages all segments that 

include that text. 

 (F7) 
check spelling. 

Deleting a project 

To delete a project: 

1. Open Wordfast and click . 

The TXML perspective appears. 
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2. Click File > Open Project. 
The Open Project dialog box appears.  

  

3. Select a project name and click Delete. 

A confirmation message appears, asking if you want to delete the file. 

4. Click Yes. 

The project is deleted and removed from the Project list. 
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WORKING WITH ADVANCED OPTIONS 
The Wordfast advanced options are as follows: 

• Managing shortcut keys 

• Managing licenses 

• Updating Wordfast 

Managing shortcut keys 

Wordfast includes a number of shortcut keys that help you quickly complete common tasks. You 

can also modify and create new shortcut keys. Find below the procedures for the following tasks: 

• Viewing shortcut keys 

• Modifying shortcut key schemes 

• Modifying shortcut keys 

• Creating shortcut keys 

VIEWING SHORTCUT KEYS 
To view shortcut keys: 

1. Open Wordfast and click . 

The TXML perspective appears. 

2. Click Help > Key Assist or press Cltrl+Shift+L. A list of actions and shortcut keys 

appear. 

MODIFYING SHORTCUT KEY SCHEMES 
To view or modify shortcut key schemes: 

1. Open Wordfast and click . 

The TXML perspective appears. 

2. Click Edit > Preferences. 

The Preferences (Filtered) screen appears. 

3. Click General > Keys. 

The Keys option appears. 
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4. Select a Scheme from the drop down list. 

Note: You can change the shortcut key scheme to Wordfast, Emacs or SDLX. You can 

also create a default scheme of your own. 

MODIFYING SHORTCUT KEYS 
To modify a shortcut keys: 

1. Follow step 1 and 3 from Modifying shortcut key schemes. 

The Keys option appears. 
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2. Left-click and select a Command. 

3. Remove the existing Binding and press a new sequence of keys. 

4. Click Copy Command. 

The shortcut key is modified. 

CREATING SHORTCUT KEYS 
To create a new shortcut key: 

1. Follow step 1 and 3 from Modifying shortcut key schemes. 
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2. Select Include unbound commands checkbox. 

The commands with no shortcut keys appear.  

 

3. Left-click and select a Command. 

4. Place the cursor in the Binding field and press a sequence of keys. 

5. Click Copy Command. 

A new shortcut key is created. 

Managing licenses 

Find below the procedures for the following tasks: 

• Re-installing license certificate 

• Verifying current license certificate 

RE-INSTALLING LICENSE CERTIFICATE 
To re-install a license certificate: 

1. Remove the current version of Wordfast from your PC by running the Uninstaller located 

at Start > All Programs > Wordfast > Uninstall. 
Note: The Uninstaller will also run automatically when you re-install Wordfast.  

2. Download the Wordfast installer from the webpage 

http://www.wordfast.com/store_download.html to your PC. 

3. Run the installer. 

The Wordfast Demo Mode appears. 
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Note: Wordfast requires a Java JRE to be installed on your PC. During installation, if 

Java JRE does not exist, it will be installed for you. If it exists, then Wordfast will refer to it 

when running. 

In the Demo Mode, you can view and test all the functions of the software. You can 

purchase a Wordfast license from the webpage 

http://www.wordfast.com/store_download.html.  

If you do not purchase a license, you are limited to storing up to 500 translation units in 

your translation memories.   

4. Buy the Wordfast license from the webpage 

http://www.wordfast.com/store_download.html. 

The license file is sent to you via email. 

5. Save the license file to a known location, preferably C:\Program files\Wordfast. 

6. Open the Wordfast Demo Mode. 

7. Click Help > License Management. 
The Activation dialog box appears. 

8. Click License Manager. 

9. Select (Re-)Install a license certificate and click Next. 

10. Browse and navigate to C:\Program files\Wordfast and select the license file. 

11. Click Next twice and then Finish. 

12. Restart Wordfast. 

Your license is active. If you have any problems with the license and require support, 

please log into the Wordfast support hotline at www.wordfast.com. 

VERIFYING CURRENT LICENSE CERTIFICATE 
To verify the current license certificate: 

1. Open Wordfast and go to Help > License Management. 
The Activation dialog appears. 

2. Click License Manager.  

3. Select Verify the current license certificate. 

The license certificate appears. It includes details of the current license. 

Updating Wordfast 

When new Wordfast builds are released, you will need to complete the necessary updates to 

access the new features. 

To update Wordfast: 
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1. Open Wordfast and click Help > Wordfast Updates.Wordfast searches for new updates 

and the search results appear. 

 

2. Select the features to be installed and click Next. 
The license agreement appears. 

3. Select "I accept the terms to the license agreements" and click Next. 
The list of features that will be installed appears. 
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4. If required, change the location where the features should be installed and click Finish. 

The new features are downloaded and your current installation is automatically updated. 

5. Restart Wordfast to activate the new build. 
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TROUBLESHOOTING ERRORS 
This section includes a list of common errors, their cause and steps that you can follow to solve 

them. 

Problem: Error message: Invalid license certificate 
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Cause: These error messages appear due to the following reasons: 

• License certificate is not a Wordfast license certificate 

• License certificate has an incorrect file name or user name 

• License certificate is edited or some information is missing from the file 

• License certificate has expired 

Solution: Contact the administrator for a new license certificate. You can contact the 

administrator by logging into the Wordfast support hotline at www.wordfast.com. 
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Problem: Error message: TXML source files missing 

 

Cause: The TXML file and the original file are not at the same location or do not have the same 

file name.  

Solution: Ensure that the TXML file and the original file are at the same location and both files 

have the same file name. If not, the clean up process cannot be completed. 

 

Problem: Error message: Translation memory header is invalid 

 

Cause: The local TM file that is being opened does not have the correct header, which typically 

includes the creation date, user ID, source and target language and so on. 

Solution: Ensure that the correct local TM is opened. If the error persists, please log into the 

Wordfast support hotline at www.wordfast.com. 
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Problem: Error message: Terminology skipped during import 

 

Cause: The source or target segment is missing from the terminology list. 

Solution: Ensure that the imported terminology list contains the source and target segments of all 

the terms. 

Problem: Error message: Unable to connect to remote TM 

Cause: The URL to the remote TM server is incorrect or invalid. 

Solution:  

1. Go to Edit > Preferences > Translation Memory > Remote. 

2. Check if the remote TM URL is correct. Find below an example of a URL string: 

gltm://french_user:french_password@63.246.29.190:47110 

3. Check if there are trailing spaces at the end. 

 

Problem: Error message: Current project and local TM have different source and target 
languages 

Cause: The source and target languages associated with the currently open project does not 

match the local TM language pair. 

Solution: 

1. Go to Preferences > Translation Memory > Local. 

2. Select the local TM and click Edit. 

3. Change the source and target languages to match the current project language pair. 
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Problem: Error message: Current project and remote TM have different source and target 
languages 

 

Cause: The source and target languages associated with the currently open project does not 

match the remote TM language pair. 

Solution: 

1. Go to Preferences > Translation Memory > Remote. 

2. Select the remote TM and click Edit. 

3. Change the source and target languages to match the current project language pair. 

 

Problem: Error message: Current project and file for translation have different source and 
target languages. 

 

Cause: The source and target languages associated with the currently open project does not 

match the file language pair. 

Solution 1: Check that you are opening the correct file. If necessary, open the file in a text editor 

and view/verify the source and target language specifications. 

Solution 2: Create a new project with source and target languages matching the file for 

translation. Go to Creating a project for more information. 
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Problem: Error message: Current project and terminology list have different source and 
target languages. 

 

Cause: The source and target languages associated with the currently open project does not 

match the terminology language pair. 

Solution: 

1. Go to Preferences > Translations > Terminology. 

2. Select the terminology and click Edit. 

3. Change the source and target languages to match the current project language pair. 

 

Problem: Translation Memory is not leveraged during translation 

Cause: A local or remote TM is not selected. 

Solution: Ensure that you are connected to a TM.  To confirm go to Translation Memory > 
New/Select TM > Local or Remote and check the Selected check box next to the TM you wish 

to use. If you have Read only selected, you will not be able to leverage or copy into the TM. 

 

Problem: Shortcut keys not working for key strokes 

Cause: The correct scheme is not selected or the shortcut key is not configured. 

Solution:  

1. Go to Edit > Preferences > Keys > Scheme. 

2. Choose the correct scheme: Wordfast, SDLX, Emacs or Default schemes. 

3. Check the shortcut key list to ensure that all shortcut keys are configured correctly. If not, 

edit accordingly. Go to Managing shortcut keys for more information on viewing, 

modifying and creating shortcut keys. 

4. Click Apply and OK. 
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